install error in vasp 5.4.4

Questions regarding compilation of VASP on various platforms.

Moderators: Moderator, Global Moderator

install error in vasp 5.4.4

Postby yjwang » Thu May 18, 2017 10:36 am

I use intel compiler (impi 4.1.1.036). The makefile is almost the same as the default one. And I got these errors.
What is the reason? Thanks.


mpiifort -free -names lowercase -assume byterecl -w -O2 -I/share/apps/intel/composer_xe_2013.5.192/mkl/include/fftw -c mpi.f90
mpi.F(429): error #6404: This name does not have a type, and must have an explicit type. [MPI_COMM_TYPE_SHARED]
CALL MPI_Comm_split_type(COMM%MPI_COMM,MPI_COMM_TYPE_SHARED,0,MPI_INFO_NULL,COMM_intra%MPI_COMM,ierror)
---------------------------------------------^
mpi.F(570): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPIMY]
USE mpimy
----------^
mpi.F(526): error #6457: This derived type name has not been declared. [COMMUNIC]
TYPE(communic) COMM
-----------^
mpi.F(534): error #6404: This name does not have a type, and must have an explicit type. [MPI_SUCCESS]
IF ( ierror /= MPI_success ) &
---------------------^
mpi.F(550): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPIMY]
USE mpimy
----------^
mpi.F(559): error #6404: This name does not have a type, and must have an explicit type. [MPI_COMM_WORLD]
call MPI_abort(MPI_comm_world , 1, ierror )
---------------------^
mpi.F(568): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [MPIMY]
USE mpimy
----------^
yjwang
Newbie
Newbie
 
Posts: 10
Joined: Tue Dec 02, 2008 6:41 am

Re: install error in vasp 5.4.4

Postby mwistey » Fri Aug 18, 2017 9:12 am

I got the same errors using intel/14.0.2 and intelmpi/14.0.2. Deleting "-Duse_shmem" from the makefile.include file seems to have allowed the compile to go farther, although that's probably going to cause other problems on large shared memory nodes. Either way, now it's failing to link:

mpi.o: In function `m_ibcast_z_from_':
mpi.f90:(.text+0x365a): undefined reference to `mpi_ibcast_'

Maybe 5.4.4 requires a newer MPI library?
mwistey
Newbie
Newbie
 
Posts: 11
Joined: Fri Sep 26, 2014 2:22 am

Re: install error in vasp 5.4.4

Postby mwistey » Wed Sep 20, 2017 10:13 pm

Update: I discovered after my previous post that my makefile.include had some problems, like extra spaces and #comments after the trailing backspace \. So the original poster might wish to check the makefile and makefile.include carefully.
mwistey
Newbie
Newbie
 
Posts: 11
Joined: Fri Sep 26, 2014 2:22 am


Return to Installation problems

Who is online

Users browsing this forum: No registered users and 1 guest