vasp 5.4.1 fails on running

Problems running VASP, runtime errors, technical questions.
Please check whether the answer to your question is given in
the VASP online manual or has been discussed in this forum
previously!

Moderators: Global Moderator, Moderator

vasp 5.4.1 fails on running

Postby nitinkr » Wed Jul 22, 2015 11:02 pm

I'm trying to install 5.4.1 using the same compiler modules etc. as I successfully did for 5.3.5. The compilation goes fine but on running a sample calculation I'm getting following error:

WAVECAR not read
entering main loop
N E dE d eps ncg rms rms(c)
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
vasp 00000000016FDD39 Unknown Unknown Unknown
vasp 00000000016FC60E Unknown Unknown Unknown
vasp 00000000016AA702 Unknown Unknown Unknown
vasp 0000000001657813 Unknown Unknown Unknown
vasp 000000000165D50B Unknown Unknown Unknown
libpthread.so.0 0000003BFEA0F710 Unknown Unknown Unknown
libmpi.so.1 00002AB33992F919 Unknown Unknown Unknown
libmkl_blacs_inte 00002AB339233253 Unknown Unknown Unknown
libmkl_blacs_inte 00002AB3392259FB Unknown Unknown Unknown
libmkl_blacs_inte 00002AB339225409 Unknown Unknown Unknown
vasp 0000000000437770 Unknown Unknown Unknown
vasp 0000000000E2A6AD Unknown Unknown Unknown
vasp 0000000000E48975 Unknown Unknown Unknown
vasp 00000000014E12BD Unknown Unknown Unknown
vasp 0000000000410D56 Unknown Unknown Unknown
libc.so.6 0000003BFE21ED5D Unknown Unknown Unknown
vasp 0000000000410C49 Unknown Unknown Unknown
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 9342 on



On doing ldd vasp I get:

linux-vdso.so.1 => (0x00007fff16c75000)
libmkl_intel_lp64.so => /home/software/rhel6/intel-14.0/mkl/lib/intel64/libmkl_intel_lp64.so (0x00002ae08caf3000)
libmkl_intel_thread.so => /home/software/rhel6/intel-14.0/mkl/lib/intel64/libmkl_intel_thread.so (0x00002ae08d217000)
libmkl_core.so => /home/software/rhel6/intel-14.0/mkl/lib/intel64/libmkl_core.so (0x00002ae08e2b1000)
libiomp5.so => /usr/cac/rhel6/intel-14.0/lib/intel64/libiomp5.so (0x00002ae08f7df000)
libmkl_blacs_intelmpi_lp64.so => /home/software/rhel6/intel-14.0/mkl/lib/intel64/libmkl_blacs_intelmpi_lp64.so (0x00002ae08faf9000)
libmpi_f90.so.1 => /usr/cac/rhel6/openmpi-1.6.5/intel-14.0.2-2/lib/libmpi_f90.so.1 (0x00002ae08fd34000)
libmpi_f77.so.1 => /usr/cac/rhel6/openmpi-1.6.5/intel-14.0.2-2/lib/libmpi_f77.so.1 (0x00002ae08ff37000)
libmpi.so.1 => /usr/cac/rhel6/openmpi-1.6.5/intel-14.0.2-2/lib/libmpi.so.1 (0x00002ae09016f000)
libosmcomp.so.3 => /usr/lib64/libosmcomp.so.3 (0x0000003bfde00000)
librdmacm.so.1 => /usr/lib64/librdmacm.so.1 (0x0000003c00600000)
libibverbs.so.1 => /usr/lib64/libibverbs.so.1 (0x0000003bffa00000)
libfca.so.0 => /opt/mellanox/fca/lib/libfca.so.0 (0x00002ae0907d5000)
librt.so.1 => /lib64/librt.so.1 (0x0000003bff200000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x0000003c04600000)
libutil.so.1 => /lib64/libutil.so.1 (0x0000003c0ba00000)
libmxm.so.2 => /opt/mellanox/mxm/lib/libmxm.so.2 (0x00002ae090a29000)
libpsm_infinipath.so.1 => /usr/lib64/libpsm_infinipath.so.1 (0x00002ae090c89000)
libtorque.so.2 => /usr/local/torque/lib/libtorque.so.2 (0x00002ae090edb000)
libdl.so.2 => /lib64/libdl.so.2 (0x0000003bfe600000)
libm.so.6 => /lib64/libm.so.6 (0x00002ae0917cc000)
libnuma.so.1 => /usr/lib64/libnuma.so.1 (0x0000003c02e00000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x0000003bfea00000)
libc.so.6 => /lib64/libc.so.6 (0x0000003bfe200000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x0000003bff600000)
libibmad.so.5 => /usr/lib64/libibmad.so.5 (0x0000003c00e00000)
libibumad.so.3 => /usr/lib64/libibumad.so.3 (0x0000003c00a00000)
libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00002ae091a52000)
libz.so.1 => /lib64/libz.so.1 (0x0000003bfee00000)
libcrypto.so.10 => /usr/lib64/libcrypto.so.10 (0x0000003c02a00000)
libssl.so.10 => /usr/lib64/libssl.so.10 (0x0000003c04a00000)
libifport.so.5 => /usr/cac/rhel6/intel-14.0/lib/intel64/libifport.so.5 (0x00002ae091da6000)
libifcore.so.5 => /usr/cac/rhel6/intel-14.0/lib/intel64/libifcore.so.5 (0x00002ae091fd6000)
libimf.so => /usr/cac/rhel6/intel-14.0/lib/intel64/libimf.so (0x00002ae092317000)
libintlc.so.5 => /usr/cac/rhel6/intel-14.0/lib/intel64/libintlc.so.5 (0x00002ae0927d5000)
libsvml.so => /usr/cac/rhel6/intel-14.0/lib/intel64/libsvml.so (0x00002ae092a2c000)
libifcoremt.so.5 => /usr/cac/rhel6/intel-14.0/lib/intel64/libifcoremt.so.5 (0x00002ae093487000)
libirng.so => /usr/cac/rhel6/intel-14.0/lib/intel64/libirng.so (0x00002ae0937f7000)
/lib64/ld-linux-x86-64.so.2 (0x0000003bfda00000)
libnl.so.1 => /lib64/libnl.so.1 (0x0000003c00200000)
libinfinipath.so.4 => /usr/lib64/libinfinipath.so.4 (0x00002ae0939ff000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002ae093c0c000)
libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x0000003c03200000)
libkrb5.so.3 => /lib64/libkrb5.so.3 (0x0000003c01e00000)
libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00002ae093f13000)
libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x0000003c02600000)
libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x0000003c02200000)
libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00002ae094119000)
libresolv.so.2 => /lib64/libresolv.so.2 (0x0000003bffe00000)
libselinux.so.1 => /lib64/libselinux.so.1 (0x00002ae09431c000)


To put it simply I use following for compilation modules:
fftw/3.3.4/intel/14.0.2
mkl/11.1
intel-comp/14.0.2
openmpi/1.6.5/intel/14.0.2




Any help is really appreciated.
nitinkr
Newbie
Newbie
 
Posts: 7
Joined: Mon Feb 04, 2013 2:44 am

Re: vasp 5.4.1 fails on running

Postby ehermes » Thu Jul 23, 2015 7:44 pm

nitinkr wrote:libmkl_blacs_intelmpi_lp64.so => /home/software/rhel6/intel-14.0/mkl/lib/intel64/libmkl_blacs_intelmpi_lp64.so (0x00002ae08faf9000)

nitinkr wrote:openmpi/1.6.5/intel/14.0.2


There is a separate MKL BLACS library for use with OpenMPI. The correct library is "libintel_blacs_openmpi_lp64.so". Please check the Intel Link Line Advisor. In addition, I have experienced trouble in the past compiling VASP successfully with the Intel 14 compilers. Try using Intel 13 or 15 (Composer XE 2013 or Parallel Studio 2015).

Eric Hermes
ehermes
Newbie
Newbie
 
Posts: 11
Joined: Tue May 14, 2013 5:45 pm

Re: vasp 5.4.1 fails on running

Postby mef362 » Thu Jul 23, 2015 8:37 pm

That looks like an error I get when I have a different version of a compiler loaded than I used to compile the code. I would suggest rebuilding everything (including vasp.5.lib) making sure everything is consistent (check your makefiles and don't use your makefiles form a earlier version).

Good luck
mef362
Newbie
Newbie
 
Posts: 8
Joined: Fri May 10, 2013 6:03 am

Re: vasp 5.4.1 fails on running

Postby nitinkr » Tue Jul 28, 2015 9:33 pm

Hi ehermes and mef362,

thank you for your suggestion. From your experience, could you please tell me what combination of (1) fftw, (2) mkl, (3) intel-comp and (4) openmpi has worked for you? thanks.
nitinkr
Newbie
Newbie
 
Posts: 7
Joined: Mon Feb 04, 2013 2:44 am

Re: vasp 5.4.1 fails on running

Postby ehermes » Wed Jul 29, 2015 3:17 pm

In my experience, Intel compilers 13 and 15 both work equally well. Use whichever version of MKL is packaged with the Intel compiler you use. You can either use FFTW3 (compiled with the same Intel compiler + MKL), or you can use the Intel FFTW3xf interface (in $MKLROOT/interfaces/fftw3xf) -- I personally typically use the Intel interface. As far as I'm aware, any version of OpenMPI should work, but I typically use MVAPICH2. If you have Intel MPI available, you can actually do the full Intel stack (Intel FFTW3xf, MKL, ifort, and Intel MPI), which also works fine in my experience. Keep in mind that you need to modify the Makefile to be consistent with the settings that the Intel Link Line Advisor specifies. If you decide to try MVAPICH2, keep in mind that the Intel Link Line Advisor does not have it listed, but you should get compatible settings if you choose "MPICH2" as your MPI implementation.
ehermes
Newbie
Newbie
 
Posts: 11
Joined: Tue May 14, 2013 5:45 pm


Return to Bugreports

Who is online

Users browsing this forum: No registered users and 1 guest