installation stops saying ...

Questions regarding compilation of VASP on various platforms.

Moderators: Moderator, Global Moderator

installation stops saying ...

Postby askhetan » Thu Sep 04, 2014 4:02 pm

today i was trying to install the new version of vasp.5.3.5

after running for some 20 mins... this is where the installation process stopped for me :
--------------------------------------------------------------------
fpp -f_com=no -free -w0 vdwforcefield.F vdwforcefield.f90 -DMPI -DHOST=\"$R_OSNAME\" -Dkind8 -DIFC -DCACHE_SIZE=4000 -DPGF90 -Davoidalloc -DNGZhalf -DMPI_BLOCK=8000 -Duse_collective -DscaLAPACK
mpif90 -FR -names lowercase -assume byterecl -O3 -ip -axAVX,SSE4.2,SSE4.1 -fp-model fast=2 -m64 -c vdwforcefield.f90
vdwforcefield.F(22): error #7002: Error in opening the compiled module file. Check INCLUDE paths. [VDWD3]
USE vdwD3
------^
compilation aborted for vdwforcefield.f90 (code 1)
gmake[1]: *** [vdwforcefield.o] Error 1
gmake[1]: Leaving directory `/rwthfs/rz/cluster/home/ak498084/Utility/vasp_5.3.5_2014/full_opt_vasp_5.3.5/build/vasp.5.3.LINUX.x64.mpi'
cp: cannot stat `vasp': No such file or directory
--------------------------------------------------------------------

I can provied the makefile(s) if needed, although i do not think the problem is related to that, it seems that the problem is related more to the particular fortran routine for the vdw forces. Where is this INCLUDE thing that I need to specify, is it in one of the makefiles of the main software/library? How can I include it? Could it be related to an extra package that was up there for download... something called "vdw_kernel.bindat.big_endian.gz" ?? please let me know

thanks in advance
askhetan
Jr. Member
Jr. Member
 
Posts: 76
Joined: Wed Sep 28, 2011 4:15 pm
Location: Germany

Re: installation stops saying ...

Postby alex » Fri Sep 05, 2014 8:14 am

Hi askhetan,

do you use a makefile of an older version?

Cheers,

alex
alex
Sr. Member
Sr. Member
 
Posts: 486
Joined: Tue Nov 16, 2004 2:21 pm
Location: Germany

Re: installation stops saying ...

Postby askhetan » Fri Sep 05, 2014 2:23 pm

So i looked at the file vdwforcefields.F ... it uses the following modules:

MODULE vdwforcefield
USE prec
USE mymath
USE base
USE poscar
USE lattice
USE constant
USE vaspxml
USE main_mpi
USE mpimy
USE mgrid
USE vdwD3

as the error says it cannot find VDWD3, i tried to locate this module. It was in this file called subdftd3.F. Now this file has only one module and that is VDWD3. This file doesn't appear in the previous versions of vasp. Do you think the error is related to a dependency because i think when the program is trying to compile vdwforcefields.F, it lacks this missing module vdwD3, which has not been compiled already.

any answers please ??
askhetan
Jr. Member
Jr. Member
 
Posts: 76
Joined: Wed Sep 28, 2011 4:15 pm
Location: Germany

Re: installation stops saying ...

Postby admin » Fri Sep 05, 2014 2:29 pm

please make sure that subdftd3 is compiled BEFORE vdwforcefield
admin
Administrator
Administrator
 
Posts: 2917
Joined: Tue Aug 03, 2004 8:18 am

Re: installation stops saying ...

Postby askhetan » Fri Sep 12, 2014 11:06 am

Dear admin, and Alex,

Thanks for your hint. It works now. There are some new routines and modules included in the vasp5.3.5 and the new makefiles had all of that. The old make file did not have those new routines included so naturally it would not have worked.

Thanks!
askhetan
Jr. Member
Jr. Member
 
Posts: 76
Joined: Wed Sep 28, 2011 4:15 pm
Location: Germany


Return to Installation problems

Who is online

Users browsing this forum: Google [Bot] and 2 guests