vasp 5.4.1 installation problems (segmentation fault)

Questions regarding compilation of VASP on various platforms.

Moderators: Moderator, Global Moderator

vasp 5.4.1 installation problems (segmentation fault)

Postby hacret » Fri Oct 16, 2015 4:32 am

I have completed the vasp.5.4.1 with gfortran 4.4.7, intel mkl 10.2.x and openmpi 1.10.0.
However I have still problem as below when it is running.

vasp_gam is no problem but vasp_std is occured segmentation fault.
What is the reason?
Please help me

error message
------------------------------------------------------------
[linux0092:16238] *** Process received signal ***
[linux0092:16238] Signal: Segmentation fault (11)
[linux0092:16238] Signal code: (128)
[linux0092:16238] Failing at address: (nil)
[linux0092:16239] *** Process received signal ***
[linux0092:16239] Signal: Segmentation fault (11)
[linux0092:16239] Signal code: (128)
[linux0092:16239] Failing at address: (nil)
[linux0092:16238] [ 0] /lib64/libpthread.so.0(+0xf710)[0x2b4475f07710]
[linux0092:16238] [ 1] /user/xdog/bin/vasp_std(mkl_blas_mc3_zdotc+0x97)[0xd4a867]
[linux0092:16238] [ 2] [linux0092:16239] [ 0] /lib64/libpthread.so.0(+0xf710)[0x2b731f9bf710]
[linux0092:16239] [ 1] /user/xdog/bin/vasp_std(mkl_blas_mc3_zdotc+0xa3)[0xd4a873]
[linux0092:16239] [ 2] /user/xdog/bin/vasp_std[0xc99970]
[linux0092:16239] [ 3] /user/xdog/bin/vasp_std[0xc940ae]
[linux0092:16239] [ 4] /user/xdog/bin/vasp_std[0xc93fa6]
[linux0092:16239] *** End of error message ***
/user/xdog/bin/vasp_std[0xc99970]
[linux0092:16238] [ 3] /user/xdog/bin/vasp_std[0xc940ae]
[linux0092:16238] [ 4] /user/xdog/bin/vasp_std[0xc93fa6]
[v:16238] *** End of error message ***


makefile.include
-------------------------------------------------------------------------------
# Precompiler options
CPP_OPTIONS= -DMPI -DHOST=\"IFC91_ompi\" -DIFC \
-DCACHE_SIZE=4000 -Davoidalloc \
-DMPI_BLOCK=8000 -DscaLAPACK -Duse_collective \
-DnoAugXCmeta -Duse_bse_te \
-Duse_shmem -Dtbdyn

CPP = gcc -E -P -C $*$(FUFFIX) >$*$(SUFFIX) $(CPP_OPTIONS)

FC = mpifort
FCL = $(FC)
#-openmp

FREE = -ffree-form -ffree-line-length-none

FFLAGS =
OFLAG = -O2
OFLAG_IN = $(OFLAG)
DEBUG = -O0
# for intel MKL
LIBDIR = /opt/lib/intel/mkl/10.2.4.032/lib/em64t
BLACS = -L$(LIBDIR) -lmkl_blacs_openmpi_lp64
SCALAPACK = -L$(LIBDIR) -lmkl_scalapack_lp64 -lmkl_gf_lp64 -lmkl_gnu_thread -lmkl_core -liomp5 -lpthread -lmkl_sequential -lm $(BLACS) -I/opt/lib/intel/mkl/10.2.4.032/include

#default
#LIBDIR = /data1/gf01/libs/
#BLAS = -L$(LIBDIR) -lrefblas
#LAPACK = -L$(LIBDIR) -ltmglib -llapack
#BLACS =
#SCALAPACK = -L$(LIBDIR) -lscalapack $(BLACS)

OBJECTS = fftmpiw.o fftmpi_map.o fftw3d.o fft3dlib.o \
/opt/intel/mkl/10.2.4.032/interfaces/fftw3xf/libfftw3xf_intel.a
INCS =-I/opt/lib/intel/mkl/10.2.4.032/include/fftw

LLIBS = $(SCALAPACK) $(LAPACK) $(BLAS)

OBJECTS_O1 += fft3dfurth.o fftw3d.o fftmpi.o fftmpiw.o chi.o
OBJECTS_O2 += fft3dlib.o

# For what used to be vasp.5.lib
CPP_LIB = $(CPP)
FC_LIB = $(FC)
CC_LIB = gcc
CFLAGS_LIB = -O
FFLAGS_LIB = -O1
FREE_LIB = $(FREE)

OBJECTS_LIB= linpack_double.o getshmem.o

# Normally no need to change this
SRCDIR = ../../src
BINDIR = ../../bin
User avatar
hacret
Newbie
Newbie
 
Posts: 9
Joined: Tue Jan 31, 2006 7:20 am

Return to Installation problems

Who is online

Users browsing this forum: No registered users and 1 guest