Page 1 of 1

Error with VASP+cRPA compiled with intel2018

PostPosted: Wed Sep 12, 2018 10:04 am
by ZhishuoHuang
Dear VASP users,

I am doing cRPA+VASP calculation (as shown in VASP wiki https://cms.mpi.univie.ac.at/wiki/index ... A_of_SrVO3), with the successfully compiled VASP 5.4.4 with the interface of wannier90 (both VASP and wannier90 were compiled with intel 2018).

However, it always runs into error:
#########################################################################
forrtl: severe (153): allocatable array or pointer is not allocated
Image PC Routine Line Source
vasp_std 00000000016E8430 Unknown Unknown Unknown
vasp_std 0000000000FAFFFC Unknown Unknown Unknown
vasp_std 00000000014216C2 Unknown Unknown Unknown
vasp_std 00000000013FBB5A Unknown Unknown Unknown
vasp_std 000000000040AE8E Unknown Unknown Unknown
libc-2.12.so 00000033BD41ED5D __libc_start_main Unknown Unknown
vasp_std 000000000040AD69 Unknown Unknown Unknown
#########################################################################

For the makefile.include, I also checked these two CPP_OPTIONS tags '-Davoidalloc and -Duse_cray_ptr', but no matter how I combine these two, the error remained.

It seems like the intel 2018 is not compatible with VASP 5.4.4. I also tried to use different version of intel to compile (intel2016, intel2014). For intel2014, I could not compile vasp succefully while though I could compile vasp with intel2016, the error still appear when doing cRPA calculation.

Could anyone please give any hint? I will appreciate it for that.

Best regards
Zhishuo Huang

Re: Error with VASP+cRPA compiled with intel2018

PostPosted: Mon Sep 17, 2018 9:26 am
by admin
Hello,

The intel compiler is compatible with VASP 5.4.4.
However, CRPA is a feature that is supported as of VASP 6.