Memory leak in GPU build?

Problems running VASP, runtime errors, technical questions.
Please check whether the answer to your question is given in
the VASP online manual or has been discussed in this forum
previously!

Moderators: Moderator, Global Moderator

Memory leak in GPU build?

Postby tfrankcombe » Wed Mar 08, 2017 11:57 pm

The memory used by Vasp running on GPUs grows as an optimisation runs.

I am doing relatively simple calculations, PBE+U on a 215 atom cell, ionic relaxation with IBRION=1 & ISIF=0. Running on 2 K80 GPUs tied to 6 CPUs, 6 MPI processes.

The queuing system imposes strict memory limits. If I give it:
30 GB the job crashes out of memory at the start of the 2nd geometry.
38 GB the job crashes out of memory in the scf of the 7th geometry.
45 GB the job crashes out of memory in the scf of the 11th geometry.

The memory use is clearly growing as the optimisation proceeds. Running the same job on 28 CPU cores gives me stable memory use of 25 GB, so this seems restricted to the GPU features. Any other similar reports?

(This looks like a bug to me, so I'm posting it here. I guess it could equally have gone in the GPU forum.)
tfrankcombe
Newbie
Newbie
 
Posts: 18
Joined: Tue Apr 12, 2016 8:19 am

Re: Memory leak in GPU build?

Postby hushujun » Thu Apr 27, 2017 5:20 am

I have experienced the same problem.
Such problem are related to all the supported ALGO (normal, fast and very fast) by vasp-GPU.
The speed of leakage is: normal>fast>very fast.
I have used the intel composerxe 2015 and 2017. The problem is not altered.
hushujun
Newbie
Newbie
 
Posts: 1
Joined: Thu Dec 24, 2009 3:04 am
Location: Shandong University, Jinan, Shandong, PR China


Return to Bugreports

Who is online

Users browsing this forum: No registered users and 1 guest