runtime error with specific input in 5.4.4

Problems running VASP, runtime errors, technical questions.
Please check whether the answer to your question is given in
the VASP online manual or has been discussed in this forum
previously!

Moderators: Moderator, Global Moderator

runtime error with specific input in 5.4.4

Postby un2 » Thu Nov 02, 2017 12:20 pm

Dear Vasp users and developers,
there is a strange issue with vasp5.4.4:
I compiled with ifort 14.0.5.212, mkl, gcc-4.9.2 and openmpi-2.1.2 (the same behaviour occurs with ompi-3.0.0).
A SCF calculation with the attached input INCAR-scf finished successfully. The following BANDS calculation
with the attached input INCAR-bands finished successfully with NBANDS <= 20 and gives a segfault for any
larger value of NBANDS.

Compiling the code with gcc/gfortran-4.9.2, opmpi-2.1.2 and scalapack-2.0.2 all calculations finished successfully
even with a large value of NBANDS (tested with 32).

1) Is it perhaps a bug in your code which can be fixed?
2) I would like to get a binary compiled with mkl and ifort from performance reason. Which ifort version is
recommended by the developers (I know about other issues with ifort 15 and like to avoid checking each version
myself...)?

Please let me know if you need further information.

Many thanks in advance and best regards,
Ulrike.
un2
Newbie
Newbie
 
Posts: 2
Joined: Fri Apr 15, 2011 3:16 pm

Re: runtime error with specific input in 5.4.4

Postby admin » Mon Jul 23, 2018 12:00 pm

no, if the job finished successfully with a different version of openmpi,
this indicates that it is not a bug in vasp, but a bug in the openmpi version you use
admin
Administrator
Administrator
 
Posts: 2911
Joined: Tue Aug 03, 2004 8:18 am


Return to Bugreports

Who is online

Users browsing this forum: No registered users and 0 guests